Small vector and matrix proposed for phobos2 now on github

Gareth Charnock gareth at oerc.ox.ac.uk
Mon Apr 26 04:37:19 PDT 2010


I need a better name for ArgList. It originally made sense because 
because I assumed I be using the tuple like this:
this(ArgList argList)

But then I ended up using it in a load of static foreaches.

I think it would be useful to actually be able to say "static foreach" 
so that readers (and writers) of the code know for sure what's going on. 
I seem to remember you starting a thread on that very matter.

bearophile wrote:
> #ponce:
> 
>> I'm not sure how your static foreach is actually static.
> 
> It's a foreach on:
> 
> template TypeNuple(T, size_t n) {
>     static if(n == 0) {
>         alias TypeTuple!() TypeNuple;
>     }
>     else {
>         alias TypeTuple!(T,TypeNuple!(T, n-1)) TypeNuple;
>     }
> }
> 
> So with the current D it's a static foreach.
> 
> Bye,
> bearophile


More information about the Digitalmars-d-announce mailing list