DMD/Objective-C Alpha 1

Michel Fortin michel.fortin at michelf.com
Thu Jun 2 03:17:59 PDT 2011


On 2011-06-02 05:30:10 -0400, bearophile <bearophileHUGS at lycos.com> said:

> From the page:
>> The ultimate goal is to merge the capabilities back into mainline DMD",
> 
> Do you want to add a syntax like this to D/DMD?
> 
> void insertItem(ObjcObject object, NSInteger value) 
> [insertItemWithObjectValue:atIndex:];

Well, that's what I'd like. Given that you can't hide completely 
selectors as an implementation detail and that programmers might need 
to specify them from time to time -- which is all the time when 
declaring extern Objective-C classes! -- I thought it'd be very much 
appreciated if the syntax for that wasn't too unreadable.

That said, if Walter doesn't like it I could change it to a more 
"standard" pragma syntax:

	pragma(objc_selector, "insertIdemWithObjectValue:atIndex:")
	void insertItem(ObjcObject object, NSInteger value);

It's more verbose and less readable, but it'd work too.

-- 
Michel Fortin
michel.fortin at michelf.com
http://michelf.com/



More information about the Digitalmars-d-announce mailing list