No subject


Sat May 31 21:40:06 PDT 2008


expand into a function call, you are making a unification. The new abstraction
is a "variable or a function call". What is this abstraction? Do you have a
name for it? If you don't, it's just a hack that saves two keystrokes and makes
the code more obfuscated. Keystroke-saving improvements should not be a design
goal in itself. 

Note that there is an analogous abstration for method calls. It's called a
"property". 

When we discuss this topic in writing, you use the syntax "run()" rather than
"run". That's because you want to be clear that you mean a function call. When
you write a program you also communicate with other programmers. You should be
as clear about the meaning as you are in our discussion. If I were reviewing
somebody else's code I would demand they use the function-call syntax. 


-- 



More information about the Digitalmars-d-bugs mailing list