[Issue 2976] rename retreatN to retreat

d-bugmail at puremagic.com d-bugmail at puremagic.com
Wed May 13 13:37:09 PDT 2009


http://d.puremagic.com/issues/show_bug.cgi?id=2976





--- Comment #1 from Kyle Foley <k-foley at onu.edu>  2009-05-13 13:37:08 PDT ---
I forgot to comment on changing the concept for the function.  I changed from:
----
size_t retreat(Range)(ref Range r, size_t n) if (isInputRange!(Range))
{
 ...
}
----
to:
----
size_t retreat(Range)(ref Range r, size_t n) if (isBidirectionalRange!(Range))
{
 ...
}

I know the first is not correct, but I am unsure about isBidirectionalRange,
since retreat really only requires popBack and empty.  It looks like the best
match without inventing isRetroInputRange or similar.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list