[Issue 5231] BigInt lacks a normal toString()

d-bugmail at puremagic.com d-bugmail at puremagic.com
Thu Nov 18 06:31:42 PST 2010


http://d.puremagic.com/issues/show_bug.cgi?id=5231



--- Comment #8 from Steven Schveighoffer <schveiguy at yahoo.com> 2010-11-18 06:30:23 PST ---
Pardon me for saying so, but that's too short-sighted.

first, it's not just a writeln/format change, it's a compiler change too.  The
compiler is the one who decides whether to store a function pointer to toString
in the TypeInfo_Struct.  Maybe you can help fix that...

Second, it's they way things currently work.  It's like saying you refuse to
have const functions because they should be inout, but inout doesn't work. 
When toString is fixed, then you can remove the crufty function, and nobody
cares whether it was ever there or not.  It looks to the outside like phobos is
immature when it can't even print its own types, regardless of how inefficient
it is.

Note that I 100% agree that the current system is crap, and needs to be
completely redone similar to how you have implemented it, but it's not how it
works now.  Can't BigInt just play along and we can push for changes to the
system without making the library look like a stubborn child?

BTW, when the system is changed, I wouldn't want it to be called toString,
since string may have nothing to do with it.  I'd call it something like format
or output.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list