[Issue 8656] New: Different naming of member base/next in TypeInfo_Const in object_.d and object.di

d-bugmail at puremagic.com d-bugmail at puremagic.com
Fri Sep 14 01:02:00 PDT 2012


http://d.puremagic.com/issues/show_bug.cgi?id=8656

           Summary: Different naming of member base/next in TypeInfo_Const
                    in object_.d and object.di
           Product: D
           Version: D2
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: druntime
        AssignedTo: nobody at puremagic.com
        ReportedBy: r.sagitario at gmx.de


--- Comment #0 from Rainer Schuetze <r.sagitario at gmx.de> 2012-09-14 01:02:12 PDT ---
In object_.d, the name of the modified type in TypeInfo_Const is called "base",
while in object.di, the declaration looks like this:

class TypeInfo_Const : TypeInfo
{
    TypeInfo next;
}

This forces you to use different namings depending on whether you compile with
druntime or something else. I recommend naming it "base" as all other TypeInfo
declarations do.

TypeInfo_Const in object.di even shadows the next() property of TypeInfo that
returns something else. Unfortunately the next field already seems to be used
in phobos, so it has to be changed there aswell.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list