[Issue 6930] combined type of immutable(T) and inout(T) should be inout(const(T))

d-bugmail at puremagic.com d-bugmail at puremagic.com
Sat Dec 21 12:56:27 PST 2013


https://d.puremagic.com/issues/show_bug.cgi?id=6930



--- Comment #20 from github-bugzilla at puremagic.com 2013-12-21 12:56:19 PST ---
Commits pushed to master at https://github.com/D-Programming-Language/dmd

https://github.com/D-Programming-Language/dmd/commit/c895ff7f1f1df0892c0c56a43c256b86592396f0
Clean up inout deduction

- Rename `Type::wildConvTo` to `deduceWild`
- Use `wildmatch` for sum of arguments match level, and use `wm` for one
parameter match level.
- Extract current workarounds for issue 6930

https://github.com/D-Programming-Language/dmd/commit/2c0ead859f208d80190d4e634b5a0737d4b64645
fix Issue 6930 - combined type of immutable(T) and inout(T) should be
inout(const(T))

https://github.com/D-Programming-Language/dmd/commit/6f4866b5b07094861c55f20165496019683242ef
Merge pull request #2992 from 9rnsr/fix6930

[enh] Issue 6930 - combined type of immutable(T) and inout(T) should be
inout(const(T))

-- 
Configure issuemail: https://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list