[Issue 4909] Two suggestions for std.algorithm.schwartzSort()

d-bugmail at puremagic.com d-bugmail at puremagic.com
Fri May 24 15:21:03 PDT 2013


http://d.puremagic.com/issues/show_bug.cgi?id=4909



--- Comment #10 from bearophile_hugs at eml.cc 2013-05-24 15:20:57 PDT ---
(In reply to comment #8)

> (On the other hand to tell the truth nowadays I write that swartz name kind of
> randomly, compile the module, and dmd suggests me the right name, that I copy &
> paste (in 2010 there was no spelling corrector). So now the situation is
> bearable).

We are back to an unbearable situation, because currently with UFCS chains D
doesn't give suggestions for wrong names:


import std.algorithm;
void main() {
    ["red", "yellow"].shwartzSort!q{ a.length };
}


DMD 2.063beta5 gives:

temp.d(3): Error: no property 'shwartzSort' for type 'string[]'


So please rename that function name to something simpler.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list