[Issue 8755] Change the order of reduce arguments

d-bugmail at puremagic.com d-bugmail at puremagic.com
Wed Feb 19 14:00:13 PST 2014


https://d.puremagic.com/issues/show_bug.cgi?id=8755



--- Comment #9 from monarchdodra at gmail.com 2014-02-19 14:00:05 PST ---
(In reply to comment #7)
> Haskell has a function call flip for this.
> http://hackage.haskell.org/package/base-4.6.0.1/docs/Prelude.html#v:flip
> 
> It turns a function taking (a, b) into one taking (b, a) instead.
> 
> In phobos this is called binaryReverseArgs.
> http://dlang.org/phobos/std_functional.html#.binaryReverseArgs
> 
> So one can use
>     rng.binaryReverseArgs!(reduce!fun)(seed);
> 
> Maybe we could rename it to flipArgs to make it useable?

Yeah... but who would actually use that in our code? I don't think it's an
acceptable solution.

After having thought and worked on this for about a year, I *think* the only
solution that wouldn't silently break code, is a rename. That or drop the issue
as "won't fix".

I suggest we use "accumulate". It's the perfect synonym.

Can we agree to go with this solution?

-- 
Configure issuemail: https://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------


More information about the Digitalmars-d-bugs mailing list