Trouble compiling gtkD under linux with gdc

Falk-Florian Henrich schreibmalwieder at
Mon Mar 19 10:23:17 PDT 2007

Am Mon, 19 Mar 2007 11:30:17 -0400 schrieb Howard Berkey:

> For dsss users:
> This dsss.conf file works fine with dmd.  Haven't tested with gdc but I
> have no reason to think it will not work, if you have correctly
> installed dsss and use it with gdc.  Put it in the top level of gtkD and
> do "dsss build".

I tried to become a dsss user, but only got:

./rebuild/rebuild -full -Irebuild sss/main.d -ofdsss
sss/conf.d:804: Error: cannot create instance of abstract class PStream
sss/conf.d:806: Error: cannot create instance of abstract class PStream

Apart from that, I tried to compile gtkD using Makefiles and gdc. I used -
m64 just to be sure it generates 64bit code. Compiling and archiving the 
object files into libgtkd.a using ar works, but as soon as I try to link 
any of the examples against it the linker goes:

gdc -L. -L.. -L../.. -static -lgtkd -ldl -lpthread -lm TEditableCells.o -
o TEditableCells
/usr/bin/ld: skipping incompatible ../../libgtkd.a when searching for -

This really looks like some kind of 64 bit problem. Any idea what that 
could be? Did anyone succeed in compiling gtkD on x86_64 so far?


More information about the Digitalmars-d-dwt mailing list