Just outright stunninly confusing

Jesse Phillips jessekphillips at gmail.com
Wed Feb 13 14:17:27 PST 2008

On Wed, 13 Feb 2008 16:57:59 -0500, Ty Tower wrote:

> John Reimer Wrote:
> Thanks John . Trying to be constructive in my criticism to give a clear
> indication as to how a new user finds it
>> I'm not sure I'm following all that's going on here.  Have you tried
>> adding "-I../dwt-linux" to your dsss command line?  If dwt-linux is
>> installed using dsss, then this addition is not necessary.  But if not,
>> you will need to provide the path to dsss like so:
>> dsss build -I../dwt-linux
> I built dwt-linux sucessfully I think with "dsss build" from the
> dwt-linux directory It built all the object files and reported no
> errors.
> I then tried the same with "dwt-samples-8d49c4eb4800" which is how it
> downloaded . Here I have got stuck with it compiling quite a lot of
> object files(mostly Tango stuff-47 in all) and then getting stuck
> looking for "-lXdamage"-below is the tail of the output.
> d/lib -Xlinker -L/usr/bin/../lib -ltango-user-dmd -ltangobos -Xlinker
> -L/usr/bin/../lib -ltango-user-dmd -ltangobos -ltango-base-dmd -lpthread
> -lm
> /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../libphobos.a
> multiple definition of `MAP_FAILED'
> dsss_objs/D/tango.stdc.posix.sys.mman.o:(.data+0x1c): first defined here
> /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../libphobos.a
> multiple definition of `FD_SETSIZE'
> dsss_objs/D/tango.stdc.posix.sys.select.o:(.data+0x4): first defined
> here
> /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../libphobos.a
> multiple definition of `RTLD_NOW'
> dsss_objs/D/tango.stdc.posix.dlfcn.o:(.data+0x4): first defined here
> /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../libphobos.a
> multiple definition of `_SIGSET_NWORDS'
> dsss_objs/D/tango.stdc.posix.signal.o:(.data+0x40): first defined here
> /usr/bin/ld: cannot find -lXdamage
> collect2: ld returned 1 exit status
> --- errorlevel 1
> Command /usr/bin/rebuild returned with code 65280, aborting. Error:
> Command failed, aborting.
> So the build won't compile.
> From your post
>> This assumes five things:
>> 1) that you want to build all the examples
> Yes I do
>> 2) that dsss (version 0.75) is properly installed and setup to use dmd
>> (version 1.025) and tango (svn version 3152)
> Just so
>> 3) that you type this command from the dwt-linux-examples directory you
>> made
> Yes
>> 4) that dwt-linux is in the parent directory.
> Yes -up one  however examples is not a sub-directory of dwt-linux -
> Should it be?
>> 5) that you haven NOT done a "dsss build dwt" and "dsss install dwt" in
>> the dwt-linux directory first. (If you did the dsss "build" and
>> "install" then there would be no need to go to all this trouble, but
>> sometimes there are unidentified conflicts due to dsss, dmd, and tango
>> being setup/installed incorrectly by the user.
> I did go back and try this to no avail except I think a couple of extra
> files were made in dwt

Your error is occurring from having phobos installed. Check in /etc/ and 
remove any dmd.conf files. It is likely that this file is pointing to 
Phobos. If you wish you may also want to make sure that /usr/local/bin 
(or where the dmd executable has been installed) has a dmd.conf file that 
point to tango libraries.

More information about the Digitalmars-d-dwt mailing list