dwt-win linking problem

Rakan Alhneiti rakan.alhneiti at gmail.com
Wed Jul 23 03:16:50 PDT 2008

torhu wrote:
> Rakan Alhneiti wrote:
>> torhu wrote:
>>> Rakan Alhneiti wrote:
>>>> Hello,
>>>> would anyone know the reason behind dwt-win not linking when it's 
>>>> built using dsss
>>>> what i get is this:
>>>> C:\d\dwt-win>Microsoft (R) Library Manager Version 5.12.8078
>>>> Copyright (C) Microsoft Corp 1992-1998. All rights reserved.
>>>> LINK : fatal error LNK1104: cannot open file "link.rf"
>>> Looks like you have the MS tools in your path before the digitalmars 
>>> ones.
>> Hello torhu,
>> i added the all D's directories paths like dsss before the tools but 
>> still get the same error.
>> I checked dsss and re-installed also but i am getting the same problem
>> here is my PATH
>> C:\d\bin;C:\d\dsss\bin;C:\d\dwt-win\;C:\Program Files\Microsoft Visual 
>> Studio\Common\Tools\WinNT;C:\Program Files\Microsoft Visual 
>> Studio\Common\MSDev98\Bin;C:\Program Files\Microsoft Visual 
>> Studio\Common\Tools;C:\Program Files\Microsoft Visual Studio\VC98\bin;
> Then there's probably no lib.exe in c:\d\bin.  Or dsss is autodetecting 
> and and making a mistake.
I have checked, c:\d\bin does contain lib.exe
If dsss is auto-detecting and making a mistake then it is a mistake the 
dwt installation files or dsss files because i have followed the exact 
instructions for windows installation in DWT's wiki.
Is there a fix?

Thanks again,

More information about the Digitalmars-d-dwt mailing list