dwt on windows

sleek cslush at gmail.com
Tue Jul 29 18:01:28 PDT 2008

I have written a very simple dwt app, but cannot get it to run properly in 
windows. Below is what I'm trying to do:

Craig at DESKTOP:C:\Documents and Settings\Craig\Desktop> dsss build -full 

This builds without issue, but when I run the executable, a console opens up 
with the following text:

CreateActCtx failed, hence theme support will not be available
Please check for:
 - missing link option -L/su:windows:5 or -L/su:console:5
 - missing link option -L/rc:dwt
 - resource file 'dwt.res' was not accessible by linker
: The specified image file did not contain a resource section.

Based on the message above, I tried the following build command:

Craig at DESKTOP:C:\Documents and Settings\Craig\Desktop> dsss 
build -full -L/su:windows:5 hifi.d

When I run the executable from the command prompt, the warning does not 
appear and the program runs with a window being displayed. However, if I try 
and double click the executable from my desktop, no window opens up.

Can anyone tell me what the proper build command is so that I can run this 
like a normal windows application? I have attached the simple code I'm 
trying to run. 

begin 666 hifi.d
M6UT at 87)G<RD-"GL-"B @("!$:7-P;&%Y(&1I<W!L87D@/2!N97<@1&ES<&QA
M>2 at I.PT*(" @(%-H96QL('-H96QL(#T@;F5W(%-H96QL*&1I<W!L87DI.PT*
M(" @('-H96QL+G-E=%1E>'0@/2 B2&5L;&\@5V]R;&0B.PT*(" @('-H96QL
M+F]P96XH*3L-"@T*(" @('=H:6QE("@A<VAE;&PN:7-$:7-P;W-E9"@I*0T*
M(" @('L-"B @(" @(" @:68@*"%D:7-P;&%Y+G)E861!;F1$:7-P871C:"@I
M*0T*(" @(" @("![#0H@(" @(" @(" @("!D:7-P;&%Y+G-L965P*"D[#0H@
M(" @(" @('T-"B @("!]#0H-"B @("!D:7-P;&%Y+F1I<W!O<V4H*3L-"GT-

More information about the Digitalmars-d-dwt mailing list