What's up with DWTx?

Jesse Phillips jessekphillips at gmail.com
Mon Nov 3 20:22:46 PST 2008

On Mon, 03 Nov 2008 19:28:42 +0100, Frank Benoit wrote:

> Jesse Phillips schrieb:
>> I'm trying to install the entire suite here. I got all the basics, DMD,
>> Tango .99.7, DSSS, and DWT 3.4-1. I even have Derelict installed to run
>> the OpenGL stuff. I am unable to get the dwt-addons to compile,
>> specifically looking at JFace. (This is all of course in Linux)
>> I just run $ dsss build from my up-to-date HG dwt-addons directory. The
>> first issue I run into is a Runnable is not a type error in JThread,
>> corrected by importing dwt.dwthelper.Runnable. Then I get the error.
>> dwtx/jface/viewers/CustomHashtable.d(54): Error:
>> dwt.dwthelper.utils.Enumeration at /usr/local/bin/../include/d/dwt/
>> dwthelper/utils.di(815) conflicts with
>> dwtx.dwtxhelper.Collection.Enumeration at
>> dwtx/dwtxhelper/Collection.d(52)
>> I'm thinking I have something in the middle of a change.
> I do not get this error. But the message seems like there are two
> include paths for dwt and dwtx. On in /usr/local/include/d/dwt and the
> other as the local folder dwtx.
> Have you solved that?

oops, I only grab the DWT bundle and skipped over the rest, then 
proceeded to us the hg for the addons :P

More information about the Digitalmars-d-dwt mailing list