Error on compiling Snippet32

Jacob Carlborg doob at
Sun Apr 7 11:11:20 PDT 2013

On 2013-03-30 02:40, John Colvin wrote:
> Fedora 18, x86_64
> Building swtsnippets[Snippet32]
> cat /home/john/Git/dwt/rsp | xargs dmd
> /usr/bin/ld:
> /home/john/Git/dwt/lib/org.eclipse.swt.gtk.linux.x86.a(org-eclipse-swt-program-Program.o):
> undefined reference to symbol 'gnome_vfs_init'
> /usr/bin/ld: note: 'gnome_vfs_init' is defined in DSO
> /lib/ so try adding it to the linker command line
> /lib/ could not read symbols: Invalid operation
> As you've probably guessed from the small cluster of pull requests, I've
> been trying to get DWT to work properly with dmd git master. Hopefully
> this is the last hurdle, but I have no clue how to get over it.

I have been able to get a VM now that can compile DWT. I've tried DMD 
from master (a few days old) and I don't get any linker errors, that 
snippet runs fine. I'm using latest Debian 32bit.

Have you tried linking with libgnomevfs-2? You can add it to the array here:

Also, make sure all libraries are 32bit.

/Jacob Carlborg

More information about the Digitalmars-d-dwt mailing list