Building DWT2 with DMD 2.062 on Windows 7 64 bit

Alexandr Druzhinin drug2004 at
Tue Feb 19 06:01:58 PST 2013

19.02.2013 20:26, Lubos Pintes пишет:
> I did exactly the same thing. And to be sure, I just tried it again.
> Nothing changed...
> Dňa 19. 2. 2013 13:55 Alexandr Druzhinin  wrote / napísal(a):
>> 19.02.2013 17:47, Lubos Pintes пишет:
>>> Hi,
>>> Just checked out fresh repository and tried to build. Base builds fine
>>> but swt doesn't.
>>> Unfortunately, I am unable to record error log.  It is something about
>>> java.lang.util.di, on line 385, opCall cannot be interpreted at compile
>>> time because it has no source code.
>>> And also that template getImportData cannot be instantiated.
>>> Sorry for ugly report. I looked into build.d. It could create the
>>> elog.txt, but it doesn't.
>>> In fact, there is no elog.txt creation. At least on win 7.
>> How did you checked out fresh repository? I had the same problem exactly
>> untill did the following:
>> $ git pull
>> $ git submodule update --init --recursive
>> in my case it solved all my troubles and I have DWT compiled with dmd
>> 2.062 on Win7 64bit
I'm sorry, updating removed some other errors. What about subject - I 
used dirty hack - I replace some file(s). For example I replace 
java\lang\util.di by util.d - to provide compiler by source code it needs.

More information about the Digitalmars-d-dwt mailing list