building ldc on raspberry pi

Kai Nacke kai at
Mon Oct 21 23:40:32 PDT 2013

On Monday, 21 October 2013 at 23:02:21 UTC, Knud Soerensen wrote:
> But I noticed cmake says:
> Found LLVM: /usr/lib/llvm-3.4 (found suitable version "3.4", 
> minimum
> required is "3.1")
> Maybe the minimum cmake accept should be raised.

Hi Knud!

That is really difficult as each architecture has a different 
state. You can use LLVM 3.1 with LDC if you are targeting 
x86/x86_64. Other targets are less mature and may require newer 
versions of LLVM. E.g. PPC64 requires at least LLVM 3.3, PPC32 at 
least LLVM 3.4.


More information about the digitalmars-d-ldc mailing list