Test results for D on Android/ARM

Joakim via digitalmars-d-ldc digitalmars-d-ldc at puremagic.com
Wed Nov 4 21:28:58 PST 2015

On Monday, 2 November 2015 at 21:13:19 UTC, Théo Bueno wrote:
> Android 6.0, LG Nexus 5 (D821), Snapdragon 800: All test pass 
> (apk)
> http://pastebin.com/W6BhWzMM

That's interesting that all the tests pass in the apk, but rsw0x 
had one test fail on the command-line on the same device.  
Usually it's the other way around, the apk is more restrictive.

On Wednesday, 4 November 2015 at 17:51:29 UTC, Austin G wrote:
> LG G4
> Android 5.1
> Snapdragon 808
> Hung on:
> core.thread
> std.parallelism
> std.container.rbtree
> std.experimental.logger.core
> std.net.isemail
> std.range.primitves
> std.regex
> std.regex.internal.thompson
> std.regex.internal.parser
> std.regex.internal.tests
> std.regex.internal.kickstart
> All other tests passed.

That's strange, others have reported no problems with Android 
5.1.  Did all these tests hang or simply fail?  When I say hang, 
I mean the test runner keeps running but nothing happens, so you 
have to close or kill it.  Whereas if a test asserts, it'll just 
say that module failed and move on to the next one.

Could be some issue related to threading, given that core.thread 
is the only druntime module on your list.  The only other cause I 
can think of is that yours is one of the few ARMv8 chips tested 
so far, but the others haven't had this problem.  Can you try 
running the other test runner, the command-line binary if you 
tried the apk so far, and see if you can reproduce or get some 
error output?  Thanks for any feedback.

On Wednesday, 4 November 2015 at 23:38:56 UTC, TheFlyingFiddle 
> On Sunday, 1 November 2015 at 05:44:04 UTC, Joakim wrote:
> Android 4.1.2, HTC 500
> The following modules fail:
> std.mmfile
> std.path
> std.process
> std.cstream
> std.socket
> std.stdio
> std.stream
> std.base64
> std.parallelism
> std.file
> std.experimental.logger.core
> std.experimental.logger.filelogger
> std.experimental.logger.multilogger
> std.range
> All modules fail with the same error:
> std.file.FileException@/home/bert/ldc/runtime/phobos/std/file.d(1802): cannot get cwd: Invalid argument

Thanks, this confirms the getcwd issue Nick reported above, on 
what is presumably an unrooted phone.  I'll try adding a 
workaround for this and let you two know once I make available an 
updated test runner.

More information about the digitalmars-d-ldc mailing list