GDC on Mac - math linker errors for do-nothing program

Chris Pelling chris at
Mon Nov 20 22:18:43 PST 2006

Hi there,

I've been using D for a while now, but only on Windows, and I'm
currently trying to get my project to compile on Mac OS X. I'm pretty
new to Macs, in general.

The machine is a classic iMac, one of the original ones from 1998; I
think it's a Revision B. (My workplace was going to throw it out so I
got it for free.) I installed a fresh copy of Mac OS X 10.3 "Panther" on
it (Tiger dropped support for the classic iMacs), downloaded and
installed Xcode Tools 1.5 as instructed, and then downloaded and
installed gdc from

To test it I created a simple D file, like this:

void main() {

I tried to compile it (using either gdc test.d or gdmd test.d) and got this:

$ gdc test.d
ld: Undefined symbols:

I have no idea what's causing this. I've tried reinstalling Xcode and
the BSD Subsystem, to no avail.

Any ideas?

Thanks in advance!

--Chris Pelling

More information about the Digitalmars-d-learn mailing list