Linking problem with QtD

Eldar Insafutdinov e.insafutdinov at
Fri Oct 30 08:51:58 PDT 2009

Qian Xu Wrote:

> Eldar Insafutdinov wrote:
> > 
> > All Qt versions keep forward binary compatibility and a full compatibility
> > within a major version, 4.5.3 contains only bug fixes compared to 4.5.2.
> > Version from is a waaaaay to old, so I would not even
> > consider it. Have you tried to turn on BUILD_EXAMPLES option in cmake? It
> > will build all examples bundled with qtd.
> The problem has been solve.
> The linker "ld" searches first in "/usr/lib" (Qt 4.4.3) and then
> my "/my-qt-sdk/lib", even when the path "/usr/lib" is not specified. 
> I checked the man page of "ld". There is an argument "-rpath-link". If it is
> not specified, the "/usr/lib" will be assumed.
> So my problem is solve. Thanks for you all. Have a nice day.

You are welcome. I'm glad you solved the problem. Yes, I should've guessed an issue, since it was missing symbols from Qt 4.5, on which QtD is based on. And it worked with version from google-code, because it was using Qt 4.4.

More information about the Digitalmars-d-learn mailing list