Resolve dub dependency

Paul Backus snarwin at
Mon Sep 21 19:38:12 UTC 2020

On Monday, 21 September 2020 at 19:16:17 UTC, JN wrote:
> I am trying to use bindbc-sdl and bindbc-wgpu at the same time. 
> The error is:
> Unresolvable dependencies to package bindbc-loader:
>   bindbc-sdl 0.19.1 depends on bindbc-loader ~>0.3.0
>   bindbc-sdl 0.19.1 depends on bindbc-loader ~>0.3.0
>   bindbc-wgpu 0.1.0-alpha8 depends on bindbc-loader ~>0.2.1
> What is the cleanest way to resolve this? I don't understand 
> why can't -sdl and -wgpu use different versions of the loader 
> library.

You can't use different versions of a library in the same library 
in the same program because library version isn't included in 
name mangling, so you'll get link errors for having multiple 
definitions of the same symbol.

More information about the Digitalmars-d-learn mailing list