<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
As first step, don't use that Tuple, use std.typetuple.TypeTuple instead. It's the same, but using the standardized name helps readability.<br></blockquote><div><br></div><div>Thanks for the correction. Tuple is indeed confusing with std.typecons.Tuple which is a struct tuple.</div>
<div><br></div><div>So here is the code again.</div><div><br></div><div><div>enum Bar;</div><div>class Foo {</div><div> @Bar int a;</div><div>}</div><div><br></div><div>void main()</div><div>{</div><div> import std.typetuple;</div>
<div> Foo foo = new Foo;</div><div> alias TypeTuple!(__traits(getAttributes, foo.a)) tp;</div><div> pragma(msg, tp);</div><div>}</div><div><br></div></div></div>