std.array suggestion

John C johnch_atms at hotmail.com
Thu Mar 9 06:31:01 PST 2006


"Oskar Linde" <oskar.lindeREM at OVEgmail.com> wrote in message 
news:dup4fr$2c0b$3 at digitaldaemon.com...
> With the corresponding inplace versions:
>
> T[] doSort(T[]);
> T[] doStableSort(T[]);
> T[] doSort(T[], delegate|function wrongOrder(T,T));
> T[] doReverse(T[]);
>

My only reservation would be the decision to prefix these functions with 
"do". It's tautological and doesn't express anything about them being 
in-place versions. I suggest just calling them sortInPlace/inPlaceSort (or 
even sortInSitu or inSituSort). 





More information about the Digitalmars-d mailing list