little thing - D and phobos naming conventions

Jarrett Billingsley kb3ctd2 at yahoo.com
Fri Oct 27 20:21:53 PDT 2006


"Chad J" <gamerChad at _spamIsBad_gmail.com> wrote in message 
news:ehuhhr$29gk$1 at digitaldaemon.com...

> We shouldn't even need that to get some kind of readln() function.  Make 
> it simple, it shouldn't need arguments (overload though for the fancy 
> stuff) just read a line from the console.
>
> Later on if we want fromString, so we can do more fancy formatted input 
> and stuff, ok, but for now I am kinda dissappointed with the /complete/ 
> lack of console input function in phobos (disregarding std.c, because 
> that's c not d and a pain to use IMO).
>
> I do miss a cheap/easy way to grab input like in C# w/ Console.ReadLine().

how about

import std.cstream;

...

int x;
float y;

din.readf("%d %f", &x, &y);

?

I agree, this should be available in std.stdio, but.. 





More information about the Digitalmars-d mailing list