toString issue

Hasan Aljudy hasan.aljudy at
Sat Sep 30 06:55:05 PDT 2006

Vladimir Kulev wrote:
> Johan Granberg wrote:
>> PROPOSAL. change all methods in object to have some prefix for to string
>> I suggest opString as the op prefix is already in use.
> I agree, and the same about toHash. Naming consistency is the right thing.

I totally disagree, what consistency are you talking about?
toString and toHash are *not* operators, so prefixing them with op is 
misleading and inconsistent.

More information about the Digitalmars-d mailing list