Things that may be removed

Max Samukha samukha at
Sat Dec 27 03:59:52 PST 2008

On Mon, 22 Dec 2008 21:45:06 +0300, "Denis Koroskin"
<2korden at> wrote:

>> could be renamed to something like "std.reflection"
>I treat the whole __traits feature as a hack. There are better  
>alternatives (discussed many times) with same functionality and better  
>syntax (Foo.traits.isAbstractClass, writefln.traits.isVirtualFunction etc  
>to name one).

There hasn't been a response from Walter to those discussions. Is it
safe to assume __traits is not going to change soon?

More information about the Digitalmars-d mailing list