Remove real type

eles eles at eles.com
Thu Apr 22 11:58:06 PDT 2010


i am for high numerical acuracy (as high as possible).
i support "real"

however:

 - maybe a better name is desirable: i work a lot with complex
numbers and "real" and "imaginary" have different meanings for me. i
would call it "continuous" or "accurate" or "precision" type

 - could we *add* a 128-bit type (eg float128)? maybe not through the
compiler, but through the standard library? or even more accurate
type...

 -finnaly, i would like standard (either through compiler or the
library) aliases for types based on the following properties:
"size" (8, 32, 64 bits etc.), "positiveness" (unsigned or signed) and
"discreteness" (the intendend one, since implementation is always
discrete) such as "continuous" or "discrete"). Examples: u8d for byte
(unsigned-8bits-discrete), u16d for uint, but s64c for double. Ok,
better names could be imagined... They would avoid implementation
"deviances" or "extensions". And, more, if one is interested in
accuracy, he should use the "real" (or, as I said, the "continuous"
type).

 -(runtime) warnings should be risen for continuous types if machine
precision limits are touched.

 - I don't like underscores in "hidden" types. Neither in __declspec
and so on. They are a testimonies for incapability of reaching
(common-sense) consensus.




More information about the Digitalmars-d mailing list