foreach_reverse is better than ever

retard re at tard.com.invalid
Sun Feb 14 18:19:21 PST 2010


Sun, 14 Feb 2010 14:26:36 -0500, bearophile wrote:

> Andrei Alexandrescu:
>> I don't mind "reversed" but it's longer than "retro" and the convention
>> doesn't scale. For example, both active and passive forms of "split"
>> look the same.
> 
> For me "retro" is acceptable. I don't love "iota" but I can accept it
> too. Other names of Phobos2 can be improved.

Agreed, these names are really confusing. To me itoa sounds like "integer 
to string" and iota "string to integer" ("to".reverse == "ot").

I can imagine using retro in code such as:

import pacman.PacmanGame;

void main() {
  if (userWants3DVoodoo) {
    // real time 3d rendering with photon mapping and 9.1 192/24 sounds
    (new PacmanGame).start();
  } else {
    // nice 8-bit graphics with mono 4-bit sound
    retro(new PacmanGame).start();
  }
}



More information about the Digitalmars-d mailing list