foreach_reverse is better than ever

Justin Johansson no at
Mon Feb 15 12:44:00 PST 2010

>>> This is a pattern in Andrei, which I think it really hurts the language
>>> (the names are very clever and funny, but that shouldn't be the point of
>>> a name, a name should be clear).
>> At least in this case being funny was not the point. I needed a name
>> that was (a) short, (b) different from "reverse", (c) memorable. It is
>> understood that other paint colors are available, but please don't
>> forget to give a little love to the painter. :o) It would be of course
>> best if names that arguably hurt the language were changed, so please
>> compile a list.
>> Andrei
> I never understood the reason for that the names need to be short. I 
> think the most important thing is that the names are clear. Just look at 
> the C standard library, it's horrible, almost every name is an 
> abbreviation of some kind.

Are you trying to start a flame war?
What's wrong with LISP's car and cdr?

Isn't it obvious to all and sundry that car is the head element
of a singly linked list and cdr is the rest of the list with the
head element removed?

Justin Johansson :-) :-) :-)

More information about the Digitalmars-d mailing list