Why is array.reverse a property and not a method?

Lars T. Kyllingstad public at kyllingen.NOSPAMnet
Tue Jul 13 01:07:21 PDT 2010


On Mon, 12 Jul 2010 14:42:49 -0500, Andrei Alexandrescu wrote:

> I'd to do some more renaming around Phobos and figure out an approach to
> deprecating names that aren't longer used.
> 
> I'm thinking:
> 
> std.conv -> std.conversion
> 
> Rationale: it's a seldom typed name so shortening it is just odd

Yes! :)


> std.stdio -> std.io
> 
> Rationale: stuttering sucks.

Oh man, YES!


> put(R, E) -> putNext(R, E)
> 
> Rationale: conveys the notion that there is progress in the output.

OK by me, but I've never seen it as a problem.


> BidirectionalRange -> DoublyEndedRange
> 
> Rationale: bidirectional suggests something that can move *in* either
> direction, whereas in fact the range can be shortened from either end.

I'd never thought of that, but it's probably a good idea.


> Would this be an improvement?

In summary, yes. :)

-Lars


More information about the Digitalmars-d mailing list