container stuff

Andrei Alexandrescu SeeWebsiteForEmail at
Wed May 26 21:07:49 PDT 2010

On 05/26/2010 09:29 PM, Michel Fortin wrote:
> On 2010-05-26 20:09:15 -0400, Andrei Alexandrescu
> <SeeWebsiteForEmail at> said:
>> On 05/26/2010 06:07 PM, Jonathan M Davis wrote:
>>> Looks interesting overall. There is one function, however, which
>>> makes no
>>> sense to me: removeElement()/stableRemoveElement().
>>> [...]
>> If the container is a worklist with items to work on, it sometimes
>> doesn't matter in which order you extract them.
> May I suggest naming it "removeAny"? This fits better with "removeBack"
> and "removeFront" (where the second word represent the position), and
> makes clear that you don't really care which element is removed.

Done. removeAny was my choice as of a few months ago but I'd forgotten. 


More information about the Digitalmars-d mailing list