std.container update

Simen kjaeraas simen.kjaras at
Thu May 27 16:50:01 PDT 2010

Jonathan M Davis <jmdavisProg at> wrote:

> wouldn't be confused with anything else. If you really want Array, that's
> Personally, I would have just gone with Vector, since it's a fairly
standard name for that sort of container and wouldn't be confused with
anything else.

I take it you don't work in simulation or games, then? Don't do much linear

While I understand the reasoning for it, I dislike the name vector for
arrays. A vector to me, is a geometric object with a length and magnitude,
not a random collection of whatevers.


More information about the Digitalmars-d mailing list