std.container update

Andrei Alexandrescu SeeWebsiteForEmail at
Thu May 27 18:06:58 PDT 2010

On 05/27/2010 06:28 PM, Jonathan M Davis wrote:
> I take it that Array is basically supposed to be std.container's version of
> C++'s vector or Java's ArrayList? If so, I would suggest that Array is not
> the best of names in that it would become very easy to confuse it with
> built-in arrays when discussing them (particularly in verbal communication
> where you can't see the capital A). Personally, I would have just gone with
> Vector, since it's a fairly standard name for that sort of container and
> wouldn't be confused with anything else. If you really want Array, that's
> fine - it should be clear enough when it's in code - but I would think that
> talking about it could easily be confusing enough that it wouldn't be the
> best of names.
> - Jonathan M Davis

Good point. Other opinions?


More information about the Digitalmars-d mailing list