improving the join function

Andrei Alexandrescu SeeWebsiteForEmail at erdani.org
Mon Oct 11 18:05:59 PDT 2010


On 10/11/2010 08:02 PM, bearophile wrote:
>> You may implement a generic std.algorithm.join, and then implement the std.string.join that uses just strings (the second argument may be a single char too) and calls std.algorithm.join for its implementation.
>
> If you don't like that name collision, the std.algorithm one may be named joinRange or something else.

This is not a matter of name collision. The new join should be a 
backward-compatible generalization of the existing one, so it should 
just work for existing calls.

Andrei


More information about the Digitalmars-d mailing list