TempAlloc review starts now

Robert Clipsham robert at octarineparrot.com
Mon Jun 6 13:28:07 PDT 2011


On 06/06/2011 20:10, dsimcha wrote:
> Seems there's a strong consensus that the "newVoid" name sucks.  I agree in
> hindsight.  Will change.

If you made it a bit more generic, it could become uninitialized!().

// int a = void;
auto a = uninitialized!int;

// double[] a = newVoid!double(100);
auto a = uninitialized!(double[])(100);

// double[][] a = newVoid!(double[])(100, 100);
auto a = uninitialized!(double[][])(100, 100);

-- 
Robert
http://octarineparrot.com/


More information about the Digitalmars-d mailing list