size_t + ptrdiff_t

Stewart Gordon smjg_1998 at
Sun Feb 19 13:16:22 PST 2012

On 19/02/2012 17:51, Manu wrote:
>     Hang on ... are we talking here about some "native int", or the int type?
> I don't really understand your resistance? I'm going to have the type when I need it, the
> question is, will it be standardised, or will I (& everyone else) invent the name and
> introduce a block of (probably not very portable) version() bullshit at the top of their
> module?

I'm not saying we shouldn't have native integer types in D.  Maybe what's needed is to be 
clearer on what's meant exactly by a native integer type.  And then add the types to 

I particularly don't understand your suggestion of the names "size_t" and "ssize_t" for 
these types.  They don't seem to me to denote the size of anything.  I guess "nativeInt" 
and "nativeUint", defined in whatever module would be suitable, would be one possibility. 
  Maybe someone has a better idea.

But knowing what code in Phobos/druntime should be using native integer types might help 
put the problem in better perspective.


More information about the Digitalmars-d mailing list