D dropped in favour of C# for PSP emulator

Peter Alexander peter.alexander.au at gmail.com
Thu May 17 09:52:26 PDT 2012


On Thursday, 17 May 2012 at 15:26:19 UTC, Andrei Alexandrescu 
wrote:
> I agree binarySearch is more precise, but I also think it's a 
> minor issue not worth the cost of changing at this point. 
> Improving names of things in the standard library is a quest 
> that could go forever, make everybody happy we're making 
> progress, and achieve no substantial gain.

No need to change anything, just add something:

bool binarySearch(Range, Value)(Range range, Value value)
{
     return assumeSorted(range).contains(value);
}

(constraints, predicates and the myriad of qualifiers/decorations 
omitted for clarity).


More information about the Digitalmars-d mailing list