D dropped in favour of C# for PSP emulator

Jonathan M Davis jmdavisProg at gmx.com
Thu May 17 11:47:14 PDT 2012


On Thursday, May 17, 2012 18:52:26 Peter Alexander wrote:
> On Thursday, 17 May 2012 at 15:26:19 UTC, Andrei Alexandrescu
> 
> wrote:
> > I agree binarySearch is more precise, but I also think it's a
> > minor issue not worth the cost of changing at this point.
> > Improving names of things in the standard library is a quest
> > that could go forever, make everybody happy we're making
> > progress, and achieve no substantial gain.
> 
> No need to change anything, just add something:
> 
> bool binarySearch(Range, Value)(Range range, Value value)
> {
> return assumeSorted(range).contains(value);
> }
> 
> (constraints, predicates and the myriad of qualifiers/decorations
> omitted for clarity).

Yeah, but then we've added a function which adds no real functionality, and we 
generally try to avoid that. So, it _might_ be reasonable to add it, but it
tends to go against how we're trying to function.

- Jonathan M Davis


More information about the Digitalmars-d mailing list