D3 suggestion: rename "range" to "sequence"

Jonathan M Davis jmdavisProg at gmx.com
Wed Oct 3 21:24:42 PDT 2012

On Thursday, October 04, 2012 06:18:51 Tommi wrote:
> On Thursday, 4 October 2012 at 03:39:20 UTC, Bernard Helyer wrote:
> > Well _I'll_ be dismissive. This idea, even if we were doing
> > the D3 thing, is completely pointless. D != maths. I don't
> > know why I have to point that out, but here we are! :P
> Some (not me) might argue that programming is a branch of
> mathematics. That aside, consistency makes it so that someone,
> who knows the term from previous math studies and starts learning
> programming, is going to have a pretty good idea what the term
> means even before it's been explained to him.

No matter how close the an idea in mathematics may be to D's ranges, it won't 
be enough to know how to use them. At minimum, you'd need additional 
documentation to understand how to use them. And the term range is quite 
accurate for what we're using it for anyway.

Changing the name would just generate more confusion, and if we were to change 
it for a hypothetical D3, it would be even worse than changing it now, because 
by then, way more people would be familiar with the term range. You wouldn't 
start using a new term for iterators just because you managed to find a term 
which was ostentsibly better would you? That would just confuse people to no 
end. And even if it's not that way with ranges quite yet, it'll be close 
enough by the time we even consider creating a new version of the language.

- Jonathan M Davis

More information about the Digitalmars-d mailing list