std.logger

Jonathan M Davis jmdavisProg at gmx.com
Thu Aug 22 15:00:52 PDT 2013


On Thursday, August 22, 2013 23:36:48 David Nadlinger wrote:
> On Thursday, 22 August 2013 at 15:51:53 UTC, Craig Dillabaugh
> 
> wrote:
> > Do you really find the three extra characters a big problem.
> 
> They are unnecessary. If you want to make clear you are dealing
> with logging, you can just write something along the lines of:
> 
> import log = std.logger;
> log.error("123");

I'd oppose warning, critical, error, etc. because they're not verbs like 
functions are supposed to be. It's variables or properties which are nouns. 
So, while I agree that the module system makes it so that the name clashes 
shouldn't be a big deal, I disagree with the names anyway and would still 
prefer logWarning to warning.

- Jonathan M Davis


More information about the Digitalmars-d mailing list