@property - take it behind the woodshed and shoot it?

Jacob Carlborg doob at me.com
Sun Jan 27 04:02:23 PST 2013


On 2013-01-26 22:48, Artur Skawina wrote:

> Hmm, the current state of them being defined by two separate functions really
> isn't ideal. But introducing new keywords or magic identifiers just for this
> does not seem right.
>
>     class A
>     {
>         private int i;
>         int foo {
>             out { return i; }
>             in(int v) { i = v; }
>         }
>     }
>
> or
>
>     class A
>     {
>         private int i;
>         @property foo {
>             int out { return i; }
>             in(int v) { i = v; }
>         }
>     }

That might conflict with contracts, which also uses "in" and "out".

-- 
/Jacob Carlborg


More information about the Digitalmars-d mailing list