I want to add a Phobos module with template mixins for common idioms.

Dicebot m.strashun at gmail.com
Tue May 7 13:25:20 PDT 2013


On Tuesday, 7 May 2013 at 19:10:23 UTC, Idan Arye wrote:
> So, we have to change it:
>
>     class Test
>     {
>         private:
>             @Property int m_foo;
>         public:
>             mixin implementAnnotations!Test;
>     }
>
> and inside `implementAnnotations` we would have to strip 
> `m_foo` out of it's prefix to get the getter&setter names.

I believe it is exactly how it should be. With changeable 
compile-time naming convention function.


More information about the Digitalmars-d mailing list