Early review of std.logger

SomeDude lovelydear at mailmetrash.com
Sun Oct 20 21:35:23 PDT 2013


On Monday, 14 October 2013 at 13:25:00 UTC, Robert Schadek wrote:
> On 10/14/2013 02:51 PM, Andrea Fontana wrote:
>> Just for comparison, on Android you can write something like:
>> FileLogger.w(...)  instead of 
>> FileLogger.log(LogLevel.Warning...)
>>
>> (and there's a "wtf" loglevel for "temporary" debugging)
>>
> hm, I don't really like it. To me it sounds like, "I'm don't 
> care about
> log level just print this". Maybe changing the LogLevel type to 
> an int
> like "debug(int) { " would be an idea and than providing some 
> immutable
> int Info = 1, Debug = 256, Error = 1024 ...  would be a idea.

IMHO, Andrea's suggestion is still a million times better.
And in any case, logger.info(...) is much better than 
logger.log(Logger.INFO, ...), which is uselessly redundant and 
quite ugly.


More information about the Digitalmars-d mailing list