std.d.lexer: pre-voting review / discussion

Dicebot public at
Wed Sep 11 13:04:20 PDT 2013

On Wednesday, 11 September 2013 at 19:58:36 UTC, H. S. Teoh wrote:
> I disagree. I think it's more readable to use a consistent 
> prefix, like
> kw... or kw_... (e.g. kw_int, kw_return, etc.), so that it's 
> clear
> you're referring to token types, not the actual keyword.

Not unless you want to change the style guide and break existing 
Phobos code ;)

More information about the Digitalmars-d mailing list