std.d.lexer: pre-voting review / discussion
public at dicebot.lv
Wed Sep 11 13:18:12 PDT 2013
On Wednesday, 11 September 2013 at 20:08:44 UTC, H. S. Teoh wrote:
> On Wed, Sep 11, 2013 at 10:04:20PM +0200, Dicebot wrote:
>> On Wednesday, 11 September 2013 at 19:58:36 UTC, H. S. Teoh
>> >I disagree. I think it's more readable to use a consistent
>> >like kw... or kw_... (e.g. kw_int, kw_return, etc.), so that
>> >clear you're referring to token types, not the actual keyword.
>> Not unless you want to change the style guide and break
>> Phobos code ;)
> How would that break Phobos code? Phobos code doesn't even use
> std.d.lexer right now.
Phobos code must conform its style guide. You can't change it
without changing existing Phobos code that relies on it.
Inconsistent style is worst of all options.
More information about the Digitalmars-d