Time to rename "D" to "@D" !?

Tobias Pankrath via Digitalmars-d digitalmars-d at puremagic.com
Mon Jun 23 15:02:25 PDT 2014


> import std.stdio;
>
> @safe int safe()
> {
> 	auto i = 8;
> 	return i;
> }
>
> void main(string ars[])
> {
> 	writeln(safe);
> 	
> }
> ---------------------------
>
> What you want is just impossible...

Would be a good use case for dfix. It really isn't hard to rename 
every identifier consistently.


More information about the Digitalmars-d mailing list