Good name for f.byLine.map!(x => x.idup)?

bearophile bearophileHUGS at lycos.com
Sun Mar 16 11:19:00 PDT 2014


Andrei Alexandrescu:

> A classic idiom for reading lines and keeping them is 
> f.byLine.map!(x => x.idup) to get strings instead of the buffer 
> etc.

Once dup/idup become free functions in object you can also write:

f.byLine.map!idup

Bye,
bearophile


More information about the Digitalmars-d mailing list