std.uni.toLowerCase / .toUpperCase

Tofu Ninja via Digitalmars-d digitalmars-d at puremagic.com
Wed Jun 24 00:03:51 PDT 2015


On Wednesday, 24 June 2015 at 05:20:38 UTC, Jonathan M Davis 
wrote:
> So, if we're going to be more consistent, I think that 
> following what we've done with splitter makes more sense, and 
> while that's ugly in this case, what you're suggestion is just 
> as ugly. And I think that I'd rather see the annoyance of 
> having toLower/toUpper and toUpperCase and toLowerCase in the 
> same module than start naming functions after adjectives - 
> especially when the resulting name is ugly like it is here.
>
> - Jonathan M Davis

If nouns are the convention we want, then one option might be to 
just introduce one function "capitalizer" and have the case type 
be an additional argument to the function, aka: 
capitalizer!lower/ capitalizer!upper/ capitalizer!title. Or 
lowerCapitalizer/ upperCapitalizer might work as well.

setExtension would then obviously translate to extensionSetter. 
Though adams idea also seems very good but with the drawback of 
some broken code.


More information about the Digitalmars-d mailing list