Sneak preview into std.allocator's porcelain
Andrei Alexandrescu via Digitalmars-d
digitalmars-d at puremagic.com
Thu May 7 07:59:31 PDT 2015
On 5/7/15 2:18 AM, Brian Schott wrote:
> On Thursday, 7 May 2015 at 02:28:45 UTC, Andrei Alexandrescu wrote:
> *Reads module name* "...toilets? Oh. Wait. This is is allocator stuff."
> Looks like there's a macro expansion problem in makeArray's "Throws:"
> IAllocator.empty and IAllocator.zeroesAllocations, CAllocatorImpl.impl,
> CAllocatorImpl.empty, and CAllocatorImpl.zeroesAllocations are missing
> Can we get a different name for "kill"? That makes me think of
> processes. How about "dispose"?
Sounds good, will do. Thanks! -- Andrei
More information about the Digitalmars-d