Our Sister

Adam D. Ruppe via Digitalmars-d digitalmars-d at puremagic.com
Thu May 26 10:50:36 PDT 2016


On Thursday, 26 May 2016 at 17:32:33 UTC, Jack Stouffer wrote:
> Well, because we already have the standard library functions 
> representation, byUTF


That would be templated so like byUTF!char and byUTF!wchar right?

Then byCodePoint can just be another name for byUTF!dchar. I 
kinda like that.

Ideally, the string type would also use lazy imports for any 
conversion table. So if you never call byGrapheme, it never 
imports the std.uni tables. (Heck, std.uni could be the one to 
provide that type, of course.)


Would an RCStr pass isSomeString? I kinda think it shouldn't. 
Actually, isSomeString probably shouldn't often be used - instead 
checking for string-like range capabilities is likely better for 
algorithms. Then doing some_algorithm(my_rcstr) fails - you must 
do some_algorithm(my_rcstr.some_range)


More information about the Digitalmars-d mailing list